EOX GitLab Instance

init.pp 1.96 KB
Newer Older
1
2
class gdal {

Martin Paces's avatar
Martin Paces committed
3
4
5
# this VM serves for re-building of the CentOS baseline 
# gdal RPM packages

6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
	package { 'ant': ensure => 'latest' }
#	package { 'atlas-devel': ensure => 'latest' }
	package { 'cfitsio-devel': ensure => 'latest' }
	package { 'chrpath': ensure => 'latest' }
	package { 'doxygen': ensure => 'latest' }
	package { 'geos-devel': ensure => 'latest' }
	package { 'ghostscript': ensure => 'latest' }
	package { 'giflib-devel': ensure => 'latest' }
	package { 'hdf5-devel': ensure => 'latest' }
	package { 'hdf-devel': ensure => 'latest' }
	package { 'jasper-devel': ensure => 'latest' }
	package { 'java-1.5.0-gcj-devel': ensure => 'latest' }
	package { 'java-1.6.0-openjdk-devel': ensure => 'latest' }
	package { 'jpackage-utils': ensure => 'latest' }
	package { 'libcurl-devel': ensure => 'latest' }
	package { 'libdap-devel': ensure => 'latest' }
	package { 'libgeotiff-devel': ensure => 'latest' }
	package { 'libjpeg-turbo-devel': ensure => 'latest' }
	package { 'libpng-devel': ensure => 'latest' }
	package { 'librx-devel': ensure => 'latest' }
	package { 'libspatialite-devel': ensure => 'latest' }
	package { 'libtiff-devel': ensure => 'latest' }
	package { 'libtool': ensure => 'latest' }
	package { 'mysql-devel': ensure => 'latest' }
	package { 'netcdf-devel': ensure => 'latest' }
	package { 'numpy': ensure => 'latest' }
	package { 'ogdi-devel': ensure => 'latest' }
	package { 'perl-ExtUtils-MakeMaker': ensure => 'latest' }
	package { 'pkgconfig': ensure => 'latest' }
	package { 'postgresql-devel': ensure => 'latest' }
	package { 'proj-devel': ensure => 'latest' }
	package { 'python-devel': ensure => 'latest' }
	package { 'ruby': ensure => 'latest' }
	package { 'ruby-devel': ensure => 'latest' }
	package { 'sqlite-devel': ensure => 'latest' }
	package { 'swig': ensure => 'latest' }
	package { 'texlive-latex': ensure => 'latest' }
	package { 'unixODBC-devel': ensure => 'latest' }
	package { 'xerces-c-devel': ensure => 'latest' }
	package { 'zlib-devel': ensure => 'latest' }
}