EOX GitLab Instance

Commit f44331b1 authored by Stephan Meißl's avatar Stephan Meißl
Browse files

Merge branch 'tmp' of /home/git/repositories/vagrant/builder_rpm

parents 369e0a9a d17a3c50
...@@ -16,11 +16,11 @@ Vagrant.configure("2") do |config| ...@@ -16,11 +16,11 @@ Vagrant.configure("2") do |config|
# please see the online documentation at vagrantup.com. # please see the online documentation at vagrantup.com.
# Every Vagrant virtual environment requires a box to build off of. # Every Vagrant virtual environment requires a box to build off of.
config.vm.box = "centos64" config.vm.box = "centos-6.4-x86_64"
# The url from where the 'config.vm.box' box will be fetched if it # The url from where the 'config.vm.box' box will be fetched if it
# doesn't already exist on the user's system. # doesn't already exist on the user's system.
config.vm.box_url = "http://downloads.eox.at/boxes/centos64.box" config.vm.box_url = "http://downloads.eox.at/boxes/centos-6.4-x86_64.box"
config.vm.hostname = "builder-rpm-vagrant" config.vm.hostname = "builder-rpm-vagrant"
...@@ -48,6 +48,9 @@ Vagrant.configure("2") do |config| ...@@ -48,6 +48,9 @@ Vagrant.configure("2") do |config|
config.vm.synced_folder "build/RPMS", "/home/vagrant/rpmbuild/RPMS" config.vm.synced_folder "build/RPMS", "/home/vagrant/rpmbuild/RPMS"
config.vm.synced_folder "build/SRPMS", "/home/vagrant/rpmbuild/SRPMS" config.vm.synced_folder "build/SRPMS", "/home/vagrant/rpmbuild/SRPMS"
# Use package caching https://github.com/fgrehm/vagrant-cachier
config.cache.auto_detect = true
# Provider-specific configuration so you can fine-tune various # Provider-specific configuration so you can fine-tune various
# backing providers for Vagrant. These expose provider-specific options. # backing providers for Vagrant. These expose provider-specific options.
# View the documentation for the provider you're using for more # View the documentation for the provider you're using for more
......
...@@ -9,7 +9,8 @@ class eoxserver { ...@@ -9,7 +9,8 @@ class eoxserver {
] ]
} }
package { 'gdal-devel': ensure => 'latest' } package { 'gdal-eox': ensure => 'latest' }
package { 'gdal-eox-devel': ensure => 'latest' }
package { 'python-setuptools': ensure => 'latest' } package { 'python-setuptools': ensure => 'latest' }
package { 'python-devel': ensure => 'latest' } package { 'python-devel': ensure => 'latest' }
} }
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment